Issues with Memory Cards in X-T3


#1

Hi,

Last week, I upgraded form the X-T2 to X-T3. I started to set it up and discovered that 3 of my 4 memory cards don’t work. I keep getting the same error message “Card not initialised” and “Read error”. My cards are always stored in a card case and they are all in excellent condition I also format them in camera immediately after I have downloaded the images.

As a last resort, I cleaned the contacts (as suggested on Fuji’s website) but still no joy. I used them in rotation with the X-T2 and never had any problem. Of the 3 cards that don’t work, I’m not worried about 2 of them as they are only 1GB which I use when I’m doing practice shots. The 3rd card is 32GB Adata (SDHC, 1, 10). The only card that works currently is a 32GB Sandisk Extreme Pro (SDHC, 3, 10).

Is anyone able to assist or shed any light?
Thanks


#2

My understanding on the X-T3 is that they need to be Class 3 cards and that would be why the Extreme Pro works and not the others. That’s what I have seen from a couple of other users but I am not 100% certain since I don’t have the XT-3 yet.


#3

Thank you, Tom. However, I’ll wait a little longer before rushing out to buy new, fast card/s.


#4

Frandi,
Try doing a deep delete on the card using your computer and a card reader then reformat the cards in the new camera. I’ve found this has worked in the past to clear the kind of problem you have. You basically need to take the memory card back to factory setting and get rid of the old formatting from the previous camera so the new camera can see the card. Would advise only doing one card to see of this works in first instance.


#5

Thanks, Simon. Tried your suggestion but it didn’t work. Still keep getting the same error messages.


#6

I have just aquired an X-T3. My complaint is not with the camera . - indeed, I am bowled over by it - but with Lightroom and Photoshop neither of which recognise the Raw files at present. I have to do a workaround, using another editing program and finally saving the files as Jpgs. Does anyone have any information on when Adobe will support X-T3 Raw file?


#7

You need to wait for the next Lightroom and Camera raw update, this could take a few weeks. Apparently it should be released in the next three weeks but that’s from an un-confirmed source. In the meantime you can use Skylum Luminar, Iridient X-Transformer or Capture One.


#8

Thanks Samual, for the information from your source, even if unconfirmed. I have been using the other programs, but I miss Adobe which is my usual first port of call .


#9

Hi Frandi,

I have same problem on X-T20 and I found that it is related to SanDisk cards only.
But SanDisk cards work on X-T3 (for me).
Check if it is one brand related.

God luck.


#10

Thanks for the info. Difficult to say whether it’s card related or not. Have been in touch with Fuji who advise X-T users should be using UHS ll cards.


#11

Probably better idea is to send it for warranty repair.